Jump to content
Game-Labs Forum

Could not get your game access details...once again


Recommended Posts

Hello gentlemen

I would appreciate an advice or help. After almost a week I tried to start the game and this appreared. I tried to reset password two times which didn't help. I found this couple months old topic: 

 Which says that this problem was already solved once.


Edited by Aceituna
Link to comment
Share on other sites

I reinstalled the game after a hardware change, and fired it up. I was able to get in and play a custom battle, then closed everything down for a time. When I attempted to open it up again and play, it came back with the "Could not get your game access details. Please try again." error message. 

Nothing seems to change it, so I suspect a server side issue?



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...