Jump to content
Game-Labs Forum
Sign in to follow this  
Nick Thomadis

Try this if you have freeze

Recommended Posts

If you noticed freezes during a battle session we strongly advise to do the following procedures:
 

Update your video card drivers
 
Essential clean-up of game folder
If you experience issues and you want to re-install the game, please proceed first to a clean up of the game folder:
 
8zmoIX.jpg
 
Step 1
Go to the Steam Library => Right click on "Ultimate General: Gettysburg" => Select “Properties”
 
89SEds.jpg
 
Step 2
In the pop-up window, go to “Local Files” tab => Click “Browse Local Files”.
 
xyCCR1.jpg
 
Step 3
You are now in the game's installation folder. Select and delete all files and folders.
 
m8IuVS.jpg
 

Step 4
Delete local content via the Steam automated process (Step 3 ensures that Steam does not leave any left overs).

 

Step 5
Right click on the game again in Steam library and re-install.

 

Step 6 (Only for Windows systems)
After installation, go into game folder as described in step 2 => Select game executables (single and multiplayer) => Right mouse button click and select "Properties" => Go into compatibility tab => Disable check box in compatibility mode panel if it is enabled.

 

 

(Optional for Windows systems) Install Microsoft Visual C++ 2010 Redistributable Package
This package is needed for many windows applications and your system may not have it properly installed. It is usually installed automatically after an installation of a game, but maybe something went wrong and you need to manually install.
 
8zmoIX.jpg
 
Step 1
Go to the Steam Library => Right click on "Ultimate General: Gettysburg" => Select “Properties”
 
89SEds.jpg
 
Step 2
In the pop-up window, go to “Local Files” tab => Click “Browse Local Files”.
 
post-42-0-01492400-1416653982.jpg
 
Step 3
Open folder "_CommonRedist".
 
post-42-0-19223600-1416653985.jpg
Step 4
Go to folder "vcredist" and then open folder "2010"
 
post-42-0-49550500-1416653987.jpg
Step 5
If your system is 64 bit then run vcredist_x64.exe else run vcredist_x86.exe and follow the instructions
 
Use alternative render
Launch game via the Steam client and choose Alternative render.
 
post-42-0-58967000-1416654459.jpg
 
Please let us know if the problem is fixed. We continue to research the matter why some Windows systems are having those freezes.

post-42-0-01492400-1416653982_thumb.jpg

post-42-0-19223600-1416653985_thumb.jpg

post-42-0-49550500-1416653987_thumb.jpg

post-42-0-58967000-1416654459_thumb.jpg

Share this post


Link to post
Share on other sites

UGG Team,

 

Can you give mac instructions for this step:

 

"Step 6 

After installation, go into game folder as described in step 2 => Select game executables (single and multiplayer) => Right mouse button click and select "Properties" => Go into compatibility tab => Disable check box in compatibility mode panel if it is enabled."

 

I am on Yosemite. 

 

Thanks!

Share this post


Link to post
Share on other sites

Hello,

Nick, thank you for this post.

The steps are clear and precise. I'm on Window 8.1 and since I did not meet any freeze. It's very ageréable!

A notion of time for this operation: 5 minutes! Not one more!

Thanks a lot

 

Verstho !

Share this post


Link to post
Share on other sites

I had 4-7 Lockups/freezes on custom/campaign. But having run the file (64 bit vcredist_x64.exe ) 'Seems' to have halted

/stopped any freezes so far played through campaign,,1x each side/few custom maps ,,just a couple

​momentary hiccups seen, hardly noticeable,,,,

Share this post


Link to post
Share on other sites

UGG team,

 

I have had occasional freezing. As stated above, I am on a Macbook OS Yosemite. Do you have suggestions for me such as the solutions you have posted for Windows users? Like what Reg. Watkins posted just above.

 

Thanks.

Share this post


Link to post
Share on other sites

i'm still having freezes.  even after completing the instructions above.

 

i have a mac desktop, os 10.6.8, nvidia ge force 8800 gs graphics card.  resolution capable of 1920 x 1200 but i'm only using 1024 x 640 as suggested.

 

very frustrating.  please fix it.  thanks.

Share this post


Link to post
Share on other sites

I have a MacBook running OS X 10.10 and I have tried playing in windowed format and unwind owed and I freeze up regardless after maybe five minutes of play.  The game looks great and I can't wait to play but it the freeze ups are frustrating.  The only way to recover is to shut the Mac down and reboot. Please get a fix soon!

Share this post


Link to post
Share on other sites

I have a MacBook running OS X 10.10 and I have tried playing in windowed format and unwind owed and I freeze up regardless after maybe five minutes of play.  The game looks great and I can't wait to play but it the freeze ups are frustrating.  The only way to recover is to shut the Mac down and reboot. Please get a fix soon!

Hi and sorry that you anticipate problems with the game.

Most users that had the same issue had system of lower specifications than advised.

Can you share what are your system specs, besides the OS?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...