Jump to content
Game-Labs Forum

Unable to reset Password


Recommended Posts


I just bought the Game and made myself a Xsolla Acount.

Put my Data in, got the conformation Mail.
Accepted that, wanted to login and ... not the correct Password.

Tried again and again ...

Ether something during to Account Creation got wrong OR my stupid Ass put some spelling Error in the Password.
Lets check that out and Reset the Password, to confirm my Theory.

Click on "Forgotten your Password?" get an E-Mail and ...
I can not click it.

This is not a button but a Background Bar, that is not clickable.
I need ether a link or a working button or i simply cannot reset my password.


Link to comment
Share on other sites



It really seems not like this is a link that I cannot open, instead I looks to me that through a Bug there never was a Link created, because if I try to right-click it. 

I cannot find the Open link, or Open Link in another Tab functions nor can I find a link if I open the Websites Background Code.

But I still tried to open it first in Chrome.
Not working.

Nether with Microsoft Edge, Firefox and the same with my Android Phone.

If you want I can provide Screenshots.


Is it possible to maybe delete the Account and I just recreate it?

Up to now there is no Acitivation Code enterd.
.... Cause I could not log in.

Or could I just make the Account on a throwaway Email Adress and later reset it to my regular Email?

Edited by Der_Nachfrager
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...