Jump to content
Game-Labs Forum
Sign in to follow this  
Michael Balsai

Stuttering movement in mac version

Recommended Posts

One of the biggest problems for me, playing the Mac version of Ultimate General Civil War is that the game will suddenly start to stutter or show really jerky motion. When this happens, it is uncontrollable. The length of time it will do this varies from a few seconds to nearly constantly and it is seemingly random if and when it starts. I have been forced to quit in disgust sometimes as the game stutters into uncontrollability. I have tried lowering the resolution, but this is totally unresponsive in the Mac version and seems not to change at all (that is it reverts back to what it was). I have also tried turning off Vsync, but again it seems to turn itself back on again at some point. These controls are really unresponsive for the most part but adjusting these in other games often helps with issues such as this. This is sad as this is otherwise a very addicting game on the mac but makes me loathe to play it because I fear I might not get to finish it (again, kind of random as I have good days and bad ones with this game).

In addition, the game can sometimes be unresponsive to pressing the buttons to activate such things as the play button or many others as well. During such times it fails to respond and nothing happens. This can sometimes happen in game when trying to press buttons such as hold or charge etc,. I use an iMac with 32 GB RAM and a video card with 4096MB VRAM (AMD Radeon R9 M395X card). It has 4 GHz Intel Core i7 processor and Retina Late 2015 27 inch screen.


What can be done to dissolve these issues?



Share this post

Link to post
Share on other sites

Hmm I haven't tried to play on my mac but for my windows I've sometimes had CPU related performance problems. Basically the game loses framerate and runs slower since the CPU can't keep up, and the result is both slow and choppy. I've only had this on maps with a ton of units on it at once, such as CSA day 3 cold Harbor or Union Chancellorsville, and usually quitting all the other stuff on my computer solved the issue.


Your problem could be a mac specific issue or a driver issue, but I think its worth checking CPU utilization to see if that is bottlenecking performance. I find it quite easy to run a ton of virtual desktops while working on my mbp so I really eat up RAM and cpu cycles on random things.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this