Jump to content
Game-Labs Forum

Infinite Loading Screen/Unable To Battle


Recommended Posts

Hello, I have wanted to play this game for a couple of years now since I discovered it’s existence but was always locked behind my Mac labtop but I was finally able to get a new windows gaming computer last night. I was super excited, I immediately set up steam, discord, etc and purchased UAD immediately. However, after I had spent 30+ minutes designing my first ship I hit launch and went to put it in the water but I never left the loading screen. I decided to be patient and wait. 30 minutes went by and it never left the loading screen. I was super frustrated and thought it was the computer at first and they recommended me poor parts that couldn’t load the game but after talking with the company I am convinced that the computer I have isn’t the issue. This morning I decided to consult the web and get some advice and someone said to try uninstalling and doing a fresh install so I did. Nothing has changed with the loading screen but I can now click and the loading screen disappears to reveal a ship unable to move and a completely grey ocean that you can also see through and see the bottom of the ship. One attempt even had the ships fighting and moving but that has only happened once with no changes to the gray ocean and nonexistent exit button, pause button, hud, etc. I have also tried toying around with the graphics to see if the absolute worst graphics settings will at least cause the loading screen to disappear on its own and load the ocean from how I’ve seen it played on YouTube at least. This did not work so I even tried going to the campaign and the naval academy to try and load any type of battle or map but I can never get out of the loading screen. With this being the #1 game I wanted with my new windows computer I am super disappointed, frustrated, and I’m not sure where to go from here and what else to try. I was told to write here by a UAD YouTuber by the name of BrotherMunro so here I am. If anyone can help me I would greatly appreciate it because I really wanted to stream this game to my YouTube channel along with other windows games I now can play but I can’t with it acting like this. Please help and thank you for reading

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...