Jump to content
Game-Labs Forum

unable to play the game now


Recommended Posts

  

17 hours ago, Eddie said:

This is ridiculous.  Paid $50 for this game over a year ago.  There have been issues with every update, but at least the game was playable.  Why can't we play the old version until you fix this issue?

 

@EddieAdmiral, please clarify if you tried the workaround I linked above?

On 10/12/2021 at 12:40 PM, Ink said:

You can also try this guide (complete it step by step):

 

 

Link to post
Share on other sites
1 minute ago, Lunar Lupine said:

I've been gone for a while and I've just tried installing vc_redist.x64.exe. The game now works.😀

I'm glad the problem the gone!

Link to post
Share on other sites
  • 4 weeks later...
On 11/7/2021 at 1:28 AM, Captain Basilone said:

well dos anyone know if there is a graphics chip better than the factory one that will work on a Inspiron 5566 laptop?

Admiral, I'd suggest to ask the question on a thematic (hardware related) forums / discords. I'm afraid you won't receive much replies here on your question

Link to post
Share on other sites
On 11/6/2021 at 5:28 PM, Captain Basilone said:

well dos anyone know if there is a graphics chip better than the factory one that will work on a Inspiron 5566 laptop?

Laptops are very rarely upgradeable. Many laptops don't come with a graphics chip or a very low performance chip because they are intended for office/school work rather than gaming. You may want to explore a gaming laptop or a desktop with a graphics card. As for recommendations based on a budget I would suggest you head over to a computer tech forum.

Link to post
Share on other sites
On 11/12/2021 at 11:44 PM, Captain Basilone said:

is an Intel(R) UHD Graphics 630 sufficient?

Admiral, I'm afraid no, this internal GPU is way below minimum requirements (Nvidia GeForce GTX 660)

Link to post
Share on other sites

I am also having an issue similar to this, but unlike some of the people on this thread that I have read, my graphics are more than enough for the game. The main menu is normal, but if I go into the naval academy, I cant start any of the battles, the buttons don't work. When I go into custom battle, it doesn't even go into the battle creator, it just stays on the main menu, and the background disappears. Upon clicking custom battle again, it goes into the menu for the custom battle, but it doesn't look as it should, and none of the buttons work, so, the game is completely unplayable :l

 

Edit: The game now seems to be playable after a recent driver update, i am not sure what changed however, my graphics were up to date prior to this

Edited by Dillpickle
Link to post
Share on other sites
On 11/21/2021 at 2:07 AM, Dillpickle said:

I am also having an issue similar to this, but unlike some of the people on this thread that I have read, my graphics are more than enough for the game. The main menu is normal, but if I go into the naval academy, I cant start any of the battles, the buttons don't work. When I go into custom battle, it doesn't even go into the battle creator, it just stays on the main menu, and the background disappears. Upon clicking custom battle again, it goes into the menu for the custom battle, but it doesn't look as it should, and none of the buttons work, so, the game is completely unplayable :l

 

Edit: The game now seems to be playable after a recent driver update, i am not sure what changed however, my graphics were up to date prior to this

Admiral, I'm glad the problem is gone after driver update

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...