Jump to content
Game-Labs Forum

Game doesn’t launch

Fast gamer

Recommended Posts

On 9/12/2021 at 3:16 PM, Fast gamer said:

When I try to open the launcher it says it is not designed to run on windows or contains an error. This is the first time this has happened and I have been playing for several months with no issue. It then says to install using the original installation media or contact support. 

Greetings Admiral. Could you please clarify if you tried to reinstall the game?

Link to comment
Share on other sites

14 hours ago, lloyd said:

Ok have reinstalled game and tried different graphics settings. When loading into battle I do not see any controls, water does not show game is not playable since last update.

Please provide PC specs as the first step. Have you managed to play the game in the past without problems you described?

Link to comment
Share on other sites

20 hours ago, lloyd said:

No problems before had the game for over a year.
GTx 1080
Intel(R) Core(TM) i7-3820 CPU @ 3.60GHz 
16Gb Ram
Windows 10 

Could you please try to Press Win+R then type: %HOMEPATH%\AppData\LocalLow\Game Labs\Ultimate Admiral Dreadnoughts

Open the folder, find settings file and delete it.

Then start the game and check if the problem persists

  • Thanks 1
Link to comment
Share on other sites

14 hours ago, Fast gamer said:

I attempted to reinstall but I still get the same problem, the launcher doesn’t open. I tried troubleshooting and it said the issue is the program is incompatible.  

Could you please clarify if you tried to reinstall following this guide:


Link to comment
Share on other sites

On 9/22/2021 at 5:53 PM, lloyd said:

Yes I have tried this uninstall and reinstall as per instructions a couple of times.


i have also checked my drivers and updated them just in case


tried it again just to be sure still no joy.


Do you mean you tried to reinstall GPU drivers? what is your video card and driver version? If you have not tried to reinstall video card drivers, please do so

  • Thanks 1
Link to comment
Share on other sites

Yes, I have trier updating and reinstalling gpu driver as well. 
Driver 9/13/2021
of note it is just UAD that has a problem.


It gets to the point where it says (flashing)  "....loading level..." , but never says "click to continue". I can hear the ocean sounds. I waited an hour just to see but nothing changed. if I click, I see the ship as per the pic provided, no controls no water. 

(tried at least twice on all of these)
Graphic settings have no effect on the  problem. 
Driver reloads no effect on the  problem.

Driver reinstalls no effect on the  problem. 

repaired game no effect on the  problem. 

Uninstalling and reinstalling  as per instructions no effect on the  problem. 

I think I can safely say that it is the game.

Edited by lloyd
Link to comment
Share on other sites

13 hours ago, Fast gamer said:

When I go to delete these files, should I delete the Xsolla launcher files, I think that they may be part of the problem. I attached a picture of the message that shows up when I tried to launch the game.

Yes, please complete all steps described here:


Link to comment
Share on other sites

  • 3 weeks later...
10 hours ago, Fast gamer said:

I have tried uninstalling and reinstalling but I still encounter the same problem. I researched some solutions to the problem, should I try these other methods as well?

Admiral, is your Windows up to date? What exact version of Windows?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...