Jump to content
Game-Labs Forum

Recommended Posts

I got back into the game hoping that, after a few months away, maybe the bugs I kept encountering previously will have been fixed, but they haven't. Anyway, I started wondering if maybe it wasn't the game, and maybe it was me misunderstanding what I'm supposed to be doing. So let me describe what happened in two battles I played, and y'all can tell me if it's the game or me that's causing these problems.

I set up a battle in 1920 between the US and Japan with 5 BBs, 3 CAs, 2 CLs, and 7 DDs on each side. I didn't get any warning about it being too many ships, and after designing my BBs I started the game. I assigned the 3 CAs to scout with 3 DDs screening them, and the 2 CLs and other 4 DDs were to screen the BBs. I turned my BBs due north to where I knew the enemy would be. Now, when I think of scouting, I understand that to mean steaming ahead of the battle line to get eyes on the enemy fleet first (think the "Run to the South" at Jutland), but instead, my CAs just chilled off to the starboard side of my BBs steaming in circles. Eventually we found the enemy, and I turned my battle line to steam a parallel course. A little while later, I noticed one of my DDs steaming off into the sunset in the opposite direction of the enemy fleet. As soon as I told it to detach from its division, it immediately turned around and headed back to where it was supposed to be. I then looked back and noticed that my other BBs were not following the flagship, but had turned and were steaming away from the enemy fleet (no, nothing was in anywhere near torpedo range by this point). At that point I quit the battle out of frustration.

I then set up a battle in 1915 between the US and Germany. Same fleet compositions but with the CAs replaced by BCs. I organized the fleet in the same way as well. Since BCs apparently can't be set to scout (which is stupid - see the Jutland example cited above), I just directed them to steam north with their screen ahead of the BBs. As the battle started, all was going well until I noticed one of the screening DDs had decided not to turn with the battle line but instead kept steaming straight into the enemy fleet, where it was quickly chewed up by every gun they had. As I returned to my BBs, I noticed that, while the flagship was doing exactly what I had told it to, the following ships were getting incrementally slower as I went back down the line, with the last two BBs basically sitting stationary in the water.

These are issues that have made the game unplayable for me every time I've tried to go back to it over the last few months. Are these because I am doing something wrong, or are these AI bugs that either the developer is unaware of or which their programmers just don't have the know-how to fix? I do remember that they weren't a problem when I first started playing, and that it seemed like they started after one of the patches several months back.

On a separate note, I did notice that the issues with some of the AI ship design absurdities have been improved, and while the ships that the AI designed for the above battles weren't exactly what I would have gone with, they weren't as comical as they were the previous times I've played. There is one very simple fix that I think they definitely need to implement, though, and that is making sure the design speeds of AI ships in my fleet are appropriate relative to that of the ships I design. For example, during the first battle I played today, the CAs were an appropriate speed for CAs, but the CLs and DDs were actually slower than my BBs, making them not really helpful for screening. Just a simple code that ensures that BCs and CAs are faster than BBs, CLs are at least as fast as BCs and CAs, and DDs are faster than all the others is something I think definitely needs to be added. 

Link to post
Share on other sites

 Dev team apparently thinks that all this game needs now is more modern superbattleship hulls, campaign and to make sure that it plays more like wows (aka bow tanking, 2" pistols sinking battleships, etc). Fleet AI isn't prioritised and in fact those described problems do exist and still weren't looked at, as well as some others. I don't play it for same reason. It's only playable with singular ship divisions, basically under manual control over every single one.
 

  • Like 1
Link to post
Share on other sites

Yeah, the fleet division bugs/quirks have been here for a while. I usually only play custom battles with a single ship class though, so I don't really experience them tbh. I just hope that the majority of the division bugs (and possibly all the division bugs) are worked out before the campaign arrives.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...