Jump to content
Game-Labs Forum

Unable to Download the Update / Play the Game


Recommended Posts

On 5/2/2021 at 2:48 AM, DreadHead said:

I have been unable to download the newest update and therefore am unable to play the game.  Please see the screenshot below:

https://photos.app.goo.gl/Mnc2RFacEUkx2eCB8

 

I have already tried a complete uninstall and reinstall of the game multiple times.

 

Please help.

 

Very respectfully,

Jeff

 

Greetings Admiral,

Please click on the mail address in the top right section of launcher and click on "Settings", then deactivate the "Use a P2P connection" option as shown on the screenshot https://imgur.com/a/VkMQIji

Link to post
Share on other sites
  • 4 weeks later...
On 5/26/2021 at 5:06 PM, DreadHead said:

This was fixed after leaving the hotel I was staying in.  I believe the ISP there was blocking the site.  Thank your for the help.

You are welcome! Glad the problem is solved

Link to post
Share on other sites
  • Ink locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...