Jump to content
Game-Labs Forum
  • 0

Cannot join kill mission battle


Go to solution Solved by Ink,

Question

New player here. I finished the exams, then grabbed my first easy kill mission from Port Royal. I go to the spot with the crossed swords and nothing happens. I saw in youtube videos that I am supposed to get a prompt to enter the battle but I do not. Am I missing something?

I assume this is also an easy question for the help chat channel in game, but I noticed that my chat does not work either. I cannot add any chat channel, and cannot input any text.

I am either missing something obvious to the vets or I stumbled on a bug. Any info/advice is welcome.

Thanks.

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
  • Solution
16 hours ago, tzervo said:

Tried all three suggestions:

1) Verified file integrity through Steam multiple times. Also tried reinstallation multiple times.

2) 3) Cleared up the %appdata% Game-Labs folder and the suggested registry entries.

Neither the issue of not being able to join mission battles nor the chat tabs missing issue was fixed.

Also, just to make sure: in terms of external dependencies, I only need the C++ 2015-2019 redistributables, correct? Do I need only the x64 bundle or both x86 and x64? In any case, I also tried with both installed but I noticed that only the x64 is needed to at least launch the game.

2013 package is also required

  • Thanks 1
Link to post
Share on other sites
  • 0

@Hands yes I did. Also worth noting that when I click on other markers (like port battles taking place in the open world between players, right outside Port Royal) works fine. I even entered one such instance to test it. But I still cannot join missions I take from ports (tried multiple ones).

Edited by tzervo
added info/clarifications
Link to post
Share on other sites
  • 0

@tzervo

Greetings Captain,

as the first steps, please try:

1) Verify integrity of game files in Steam (right click on Naval Action in Steam, click on properties->local files)

2) https://forum.game-labs.net/topic/19975-workaround-for-certain-ui-loading-problems-inlcuding-trader-tool/

3) https://forum.game-labs.net/topic/19975-workaround-for-certain-ui-loading-problems-inlcuding-trader-tool/?do=findComment&comment=542624

Link to post
Share on other sites
  • 0
5 hours ago, Ink said:

@tzervo

Greetings Captain,

as the first steps, please try:

1) Verify integrity of game files in Steam (right click on Naval Action in Steam, click on properties->local files)

2) https://forum.game-labs.net/topic/19975-workaround-for-certain-ui-loading-problems-inlcuding-trader-tool/

3) https://forum.game-labs.net/topic/19975-workaround-for-certain-ui-loading-problems-inlcuding-trader-tool/?do=findComment&comment=542624

Tried all three suggestions:

1) Verified file integrity through Steam multiple times. Also tried reinstallation multiple times.

2) 3) Cleared up the %appdata% Game-Labs folder and the suggested registry entries.

Neither the issue of not being able to join mission battles nor the chat tabs missing issue was fixed.

Also, just to make sure: in terms of external dependencies, I only need the C++ 2015-2019 redistributables, correct? Do I need only the x64 bundle or both x86 and x64? In any case, I also tried with both installed but I noticed that only the x64 is needed to at least launch the game.

Link to post
Share on other sites
  • 0
On 3/31/2020 at 5:03 PM, tzervo said:

New player here. I finished the exams, then grabbed my first easy kill mission from Port Royal. I go to the spot with the crossed swords and nothing happens. I saw in youtube videos that I am supposed to get a prompt to enter the battle but I do not. Am I missing something?

I assume this is also an easy question for the help chat channel in game, but I noticed that my chat does not work either. I cannot add any chat channel, and cannot input any text.

I am either missing something obvious to the vets or I stumbled on a bug. Any info/advice is welcome.

Thanks.

Do you have the correct rank ship for the mission (for example, are you trying to take a 6th rate into a 7th rate kill mission)?

  • Like 2
Link to post
Share on other sites
  • 0

@GrubbyZebra yep, Basic Cutter going into rank 7 mission.

@Ink installing the 2013 redistributable did the trick - both mission instances and chat work now, thanks a lot!! Marking it as solved.

Thanks to @Hands and @GrubbyZebra for the recommendations and sanity checks as well, they were useful nevertheless.

@Ink, I would recommend to bundle the necessary redistributables (I have seen other games do it and it is quite convenient) with the installation or at least display a message on the game's start the way it is done with the 2017 redistributable. That might save other players confusion and frustration. In any case, thanks again for the quick replies and resolution.

Edited by tzervo
marking solution with bold for other readers
  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...