Jump to content
Game-Labs Forum
OjK

Stuck on Loading. AGAIN

Recommended Posts

Guys the problem might be you didn't download the "Limited Displacement" DLC.  It's only $10.  If you log in with it, you cause an enemy player to get stuck in loading screen.  Have you used it?

 

j/k admin don't ban me

  • Like 2

Share this post


Link to post
Share on other sites
Just now, Papillon said:

Guys the problem might be you didn't download the "Limited Displacement" DLC.  It's only $10.  If you log in with it, you cause an enemy player to get stuck in loading screen.  Have you used it?

 

j/k admin don't ban me

Dammit....another ten bucks!

 

Share this post


Link to post
Share on other sites

So, what's everyone up to this fine morning?  Obviously sailing is not one of the things we are doing...
It's daylight savings time here in the pacific northwest, was hoping for an extra hour of gaming this morning, but that's not happening. 
So, now i'm cleaning my desk and doing laundry.  Domesticated, i know.

 

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Mascarino said:

The russians should make use of this time and cap the rest of the map

Work in progress.

Share this post


Link to post
Share on other sites

Devs really need to get this sorted, for a full release game this issue should have been inspected, the issue ascertained and a fix rolled out.

Are we going to get compensation due to not being able to get on?

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Shane_Martin said:

Devs really need to get this sorted, for a full release game this issue should have been inspected, the issue ascertained and a fix rolled out.

Are we going to get compensation due to not being able to get on?

It is so frustrating.

I was happily playing then it said lost connection and would reconnect etc.

Still waiting !

Share this post


Link to post
Share on other sites
2 minutes ago, Hugh Latham said:

As I said, this never happened to me before. Must be something to do with the new server?

I’m sorry to all those also effected.

But at least I know it’s not my end

Edited by contact

Share this post


Link to post
Share on other sites

Forget war server, let's all go pve and change for full PvP.....only a joke

  • Like 1

Share this post


Link to post
Share on other sites

They need to change the server announcement to "Server downtime 60 to 300 minutes"

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Hugh Latham said:

As I said, this never happened to me before. Must be something to do with the new server?

 

Also my theory. :mellow:

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Shane_Martin said:

Port battles are still being set, surely if this issue happens the port battles shouldn't count?

image.png.85f12670385e3b71bd262f7e6da10239.png

Against newtral Ports? Seriusly? 

Share this post


Link to post
Share on other sites
6 minutes ago, Shane_Martin said:

Port battles are still being set, surely if this issue happens the port battles shouldn't count?

image.png.85f12670385e3b71bd262f7e6da10239.png

LMAO....seriously, are you that worried?  Compensation and now "gimme a mulligan"...it's a game, calm down.  Go outside and breathe, see the sky, the grass....or jump into the ocean and swim around if you're able.  It'll be ok.

 

Share this post


Link to post
Share on other sites
3 minutes ago, Moghra said:

Has their support team acknowledged this issue yet?

Yes 

Say they are aware and trying to sort it

Share this post


Link to post
Share on other sites
Just now, Citoyen J said:

Same  problem.....

is it planned to solve FINALLY this recurring problem?

Who knows !

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...