Jump to content
Game-Labs Forum

Getting low FPS on a fairly decent machine


Recommended Posts

I replaced my desktop about a year ago to replace my ageing Dell XPS monster (in size).

 

Currently running an ASUS CM6870|i7 Quadl Core|12GB DDR3 RAM| 2TB HDD|GeForce GT630 - 2GB|Windows 8|Realtek 6.1 sound.

 

Getting 13-15 fps and the video settings panel is very limited.

 

I know the GT630 is basically crap although even at these slow fps numbers the game is very playable.

 

On the off chance that I could have possibly missed something, is anyone using a similar card and getting better performance?

 

Thanks for any pointers.

Link to post
Share on other sites

Thank you both very much.

I got a slight increase, but not much.

 

Still, as long as I can play reasonably smoothly, I can't really complain.

 

Will probably have to invesr in a better card in the end.

Link to post
Share on other sites

In the ingame menu you have Graphics Settings: Low, Medium, High, Ultra, Custom.

 

Click Custom ---> disable antistrophy. I noticed no visual change but gained around 20(!!!) FPS.

 

Thank you so much for this tidbit of info! It has helped me a great deal. This info needs to be stickied, it's that helpful & important.

  • Like 1
Link to post
Share on other sites

The GT630 is in no way decent. A card such as the GTX 750 or the R7 265 would match that description. Just build your own rig next time and get a substantial increase in price/performance. Anybody can do it these days and there is tons of build tutorials on the internet. Fortunately the game itself is already quite well optimized because it uses Unity.

Link to post
Share on other sites

Not many realize the difference between a 2 GB GT card and a 2GB GTX card. 

 

pics speak a thousand words, so they say:

 

http://i6.photobucket.com/albums/y230/asleka/geforce-gt-630-3qtr_zps29fdc419.png~original

vs

http://i6.photobucket.com/albums/y230/asleka/asus-geforce-gtx-660-directcu-ii-top-14_zps53ef79f0.jpg~original

 

Notice the PCe interface for reference. 

 

My current machine had the 2GB GT620 card in it when I bought it.. the card fit inside my palm. I replaced it with a GTX 660 which nearly filled the middle section of the computer. 

Link to post
Share on other sites

In the ingame menu you have Graphics Settings: Low, Medium, High, Ultra, Custom.

 

Click Custom ---> disable antistrophy. I noticed no visual change but gained around 20(!!!) FPS.

 

can you guys confirm that this brings +20 fps boost for everyone? 

Link to post
Share on other sites

GT730 stands in the parameters with the same GT630, knocked all the settings in the control panel Minimal. In the game, if you disable anisotropic filtering OFF settings of the game the rest of the graphic medium., FPS 12-18, 32 monitor, connecting 21 Monitor FPS 20-30. Overclock the processor A-8 to 4100 (by default 3600 g)

A measurable increase in FPS at all magical actions do not.

It remains only to disperse vidyuhi.

post-5195-0-15644100-1422288288_thumb.jpg

Link to post
Share on other sites

can you guys confirm that this brings +20 fps boost for everyone? 

 

I get around 10 extra Fps by turning it off.  Gtx 980 card. means i get a bit over 100 fps.  the biggest problem i have noticed is the huge fps drop in huge battles, with stuff on max. i drop down to around 35-50 fps. but im running the game in 2560x1440 :D But as it's only a alpha. i dont mind it. it's pritty stable so far! but since i run 2 monitors. i minimize the game alot of times. looks like it dont lock the mouse to the fullscreen game.

Link to post
Share on other sites

can you guys confirm that this brings +20 fps boost for everyone? 

Can confirm that it brings a boost. I went from 54+ to 64+ the instant I turned it off. As I watch my ship sink.. I notice that it is 78 fps. (GTX 660)

Link to post
Share on other sites

As far as i know antializing isn t working yet - so there should be no point in turning it on.

I have about 35-40 fps when it s turned on and 50-60 when antializing is turned of.

I m using a Gtx 680 with 4 gbs and playing on 1080p.

Link to post
Share on other sites
  • 11 months later...

Did you try to turn Anti aliasing off? That might help to inrcease FPS

 

Hi
No, the anti aliasing is on x2 or x4, I am going to deactivate him, thank you for your answer ;)

Edit:

Works one thank you to you !  :D

Edited by Terence44
  • Like 1
Link to post
Share on other sites

Hi all. I just paid for and downloaded the game and i have some major FPS issues i hope u guys can help me figure out.

 

My computer is a MSI GE60 laptop with Intel-Core i7-4700MQ processor, Nvidia GeForce GT750M/2GB GDDR5 CPU, and 8gb ram/memory. I run all games fairly smooth (World of Tanks for example- all settings on max and 50FPS). On Naval Actions however when i turn on ULTRA i got 9fps, with it on low (with anisotropic toggled OFF)  i got 35fps but i cant play it like that because it takes all the fun away.. any ideas?

 

This one guy on this forum said it should smooth and referring to UNITY but that guy must be a LIAR lol

Link to post
Share on other sites
×
×
  • Create New...