Jump to content
Game-Labs Forum
Captain_Avatar

Rudder not centering issue - still...

Recommended Posts

I'm still having the issue of not being able to centre the rudder due - to I assume - the JS, etc drivers I have.

 

Just wondering if the Devs have some type of time frame when a fix may be scheduled?

 

I know there was an attempt to do this on the 9th but caused other issues.

 

Cheers

Share this post


Link to post
Share on other sites

I have an identical issue, experience from previous Unity based games has always been the Joystick inputs.

Sadly this isn't as simple as "unplugging the joystick" as multiple peripherals have inputs windows classes as a joystick.

Share this post


Link to post
Share on other sites

I didn't have this problem until last night, my first bunch of times playing were fine.

 

Last night my rudder was stuck hard left the whole game, unless I went into the free-look camera than it would centre again

 

I'm sure it is joystick related, as mine is plugged in... but I tried unplugging it and nothing changed

Share this post


Link to post
Share on other sites

I had this problem until yesterday (11 jan) when i unplugged all devices except for keyboard and mouse, along with turning off the profiles for my JS, rudder pedals and mouse, i didn't uninstall the drivers so that was not the problem for me. 

Share this post


Link to post
Share on other sites

look if you have VJOY installed it messed up AC4 when i installed it because i had my joystick pluged in.

remove it and you should be good to go if not then it is something else

 

and dont forget gamelog files

Share this post


Link to post
Share on other sites

Never had this problem before today's patch, done 2 matches and i can't have the rudder to auto center anymore now.

 

No joystick or USB device connected on PC, happend just after today's 12MB patch. Got an azerty layout keyboard and rudder is set to Q & D keys.

 

The 2 tries were done with the Suprise ship, will try another one and try to delete my controls regkey then and reset controls to default, barely possible to shoot and hit with no auto center on rudder :/ 

Share this post


Link to post
Share on other sites

It is since the last update today 14/01/2015. I have the same problem and I do not have any joystick plug into my PC! :o

Share this post


Link to post
Share on other sites

I tried also using the arrow keys on the keyboard for the rudder and same issue so probably not a rebinding issue on my azerty keyboard, it needs now to be re-centered manually ( more or less ) using the controls left and right or it remains where you leave it once you release the keybinds controls for the rudder with no more auto center, sent a F11 report in game for this.

Share this post


Link to post
Share on other sites

I had the same trouble some time ago. I disconnected my joystick and my rudder pedals, and it didn't solve the problem. I re-connected my joystick, and VOILA!. I believe the game looks at your joystick as the primary input device, and then to your "A" and "D" keys as a secondary input. What I believe MIGHT have happened is that now the game recognises that I have a joystick, and it's input is centred. If I then move it out of the way on my desk (still leaving it connected) it senses zero rudder input. If I then apply "A" or "D", it senses that and moves accordingly. It (of course) also senses a double tap for full lock, and a single tap in the opposite direction to re-centre it.

 

Hope that somehow helps.

 

post-6995-0-06349300-1421316507.gif

 

 

Share this post


Link to post
Share on other sites

I did an F11 bug report last night on behalf of others in game statements.

 

My own ship was not effected, but several of the frigates in game reported this issue, to the point they were sailing into the wind and getting their ships stuck in irons.

 

Do we have confirmation if it is controller based or ship class ?

 

(I use keyboard and mouse for the game but do have a thrustmaster hotas X plugged in permanently which did not seem to cause me any problems)

Share this post


Link to post
Share on other sites

Crankey,

 

This problem was only evident in my first six or so games (until I solved the problem as described above), so it did only occur on my first vessel, the Lynx. Since then I have progressed, and it has not reappeared on other vessels.

 

It is almost certainly controller based. I have a Saitek X52 and rudder pedals plugged in (though also not affecting my play).

 

post-6995-0-19245900-1421320579.gif

Share this post


Link to post
Share on other sites

I have a AZERTY keyboard and have two BIG problems with the keyboard.

 

1) I reassigned some keys like 'Q' instead of 'A', 'Z' instead of 'W'.

Alle keys work fine except the double click. When I double click 'D' the rudder is fixed at the right, but hidding 'Q' it is not released. I need to hit 'A' key to release the rudder. But since the 'A' has been assigned to the sails, my sails changes to manuel. Additionaly double click 'Q' does not fix the rudder at the left. I never tried to double click on 'A', I will at next occasion.

EDIT : I tried, a double click on 'A' locks the rudder at left and is unlocked with 'D'.

Apparently I can assign all functions of the boat to any desired key. Except the double click which are fixed to the 'Q' and 'D' keys. Couldn't you fix the double click to the function except to the key itself ???

 

2) I have on a irregular basis rudder problems. The rudder does not center after releasing key Q or D.

Some days I have, other days not. There are more days with the problem then without.

I cleared the registry and reassigned the keys again.but the problem remain. I also tried the solution described above, but this does not help.

Edit : Each time I edit the registry, and ressaign the keys, rudder works fine. Untill ... I close the game and reopen it, then the same problem reappears.

 

These two problems makes that the game is difficult to play.

I sometimes leaves a game because I'm to tired having this problems, it is not fiun anymore.

Hope this will be solved.

Mael

  • Like 1

Share this post


Link to post
Share on other sites

Well I have to say that since the last patch I am now able to use the rudder properly for the first time.

I did delete Vjoy, unplug my pedals and TM Warthog HOTAS and reinstall the game, but I'm more than happy - certainly was not going to delete my drivers for the JS etc.

Cheers

Share this post


Link to post
Share on other sites

i try the tuto but i don't get the software>defautlompany/NA files and then i can't delete it.

My rudder don't get back in middle so i can't play the game so far.

 

Ty to correct this new bug

Share this post


Link to post
Share on other sites

I get this issue if I start the game with my joystick plugged in. Unplugging after the game has started does not help, I have to quit, unplug, then restart the entire program to fix it.

Share this post


Link to post
Share on other sites

Ok, no joystick here (but has been used with my rig as well as pedals BEFORE installing NA, hence: uninstalling any drivers, plug in devices?) and got the non-centering rudder-bug now for the first time, playing with the new patch for some time since.

 

Appreciate any help as I am very bad at aiming/tacking and checking a so-and-so centered rudder at the same time :(

 

Edit: And yes, I did erase the input data in the NA registry, then to start with new/default key-bindings.

 

And a (kind of final?) edit: I found somewhere here that it is important to assign "first" and "second" input to the same key (2x2 lines!)

 

This worked for me - so far.

Share this post


Link to post
Share on other sites

You need to delete vjoy drivers, unistall, delete registry key, reinstall problem is gone.

 

I had the problem did this no problem anymore. You do not need the vjoy drivers unless you have a really old joystick like pre 2001 non USB joystick. I still use my thrustmast 16000M for elite dangerous and it works fine with no problems on NA.

  • Like 1

Share this post


Link to post
Share on other sites

You need to delete vjoy drivers, unistall, delete registry key, reinstall problem is gone.

 

I had the problem did this no problem anymore. You do not need the vjoy drivers unless you have a really old joystick like pre 2001 non USB joystick. I still use my thrustmast 16000M for elite dangerous and it works fine with no problems on NA.

 

Thanks for the advice: looks like I never had installed vjoy-drivers - or: what to look for and where?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...