Jump to content
Game-Labs Forum
admin

TESTBED - Port User Interface Feedback.

Recommended Posts

@admin I have the colourblind mode activated (as I am colourblind - not just prefer it) and the font colour for low (not enough) crew - I presume to be red - is very hard to distinguish that it is different than when a ship reaches min. crew on the sliding scale.

Share this post


Link to post
Share on other sites

The building counter is misleading. The building cap is the same so 5 or 10 for the whole server. The building counter should show your total buildings not how many you have in port.

20180927194858_1.jpg

  • Like 1

Share this post


Link to post
Share on other sites
Guest
6 hours ago, Wraith said:

So, I've spent quite a few hours now with the new interface and I feel like I can give an informed opinion on many issues.

The art is amazing, it looks great and fits the feel of the game that I think many of us have in mind. Well done.

The interface and design of the UI, focused on a multi-window paradigm, seems better suited to displaying that art than on usability. In short, it's horrible from a usability standpoint. It takes three clicks where it should take one, as a general rule. And often it takes even more because the layout of the multiple windows almost always requires you to move those windows around the screen multiple times to cover/uncover various other aspects of the UI to get anything done.

Scaling is a huge issue. UI elements could be half their size or even smaller. I've asked for it multiple times since the OW UI was changed, but the scaling of these UI elements should be user configurable because as it is, across multiple monitors or screen resolutions the UI elements are outrageously large and difficult to deal with. The basis of the default Unreal Engine UI elements is far, far preferable than the non-scaling, new elements. I would urge the developers to do a full rework of the elements that allow for not just optional scaling, but also configurable icon vs. list views.

Furthermore, the list-only warehouse/hold views is incredibly frustrating compared to the ability to sort and organize our holds/warehouses as we see fit. All of these things could be stored locally and the overhead could be minimal but improve usability significantly.

The usability must be improved before launch because new users who buy this game at launch will be twice as frustrated as those of us who know that the feature exists but just can't find it. If it were up to me, I would scrap the multi-window paradigm completely. I would re-skin the existing UI elements, keep the addition of the hot key elements which is a nice usability addition, as well as significant mouse-over information as these all will aid the new user and veteran alike. 

As of now, I would honestly buy a DLC that gives me the old interface elements back, despite the attractiveness of the art.

Well said. I agree with all points. I have ended my effort to achieve the reward ship. Too frustrating

Edited by Guest

Share this post


Link to post
Share on other sites
3 hours ago, Rabman said:

Yes, but the unstuck command is needed. a Clan mate was stuck on a rock in the open world, and could not get off of it; I think that's what prompted Aster OP.

It wouldn't be an Age of Sail game without the potential to become shipwrecked.  :D

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Angus MacDuff said:

Whoa...I entered battle well inside Puerto de Nipe and when I came out, I was way outside the harbour....that's a big change and seems very random

 

Same issue here. I entered battle outside ocean bight and appeared at little inagua afterwards

Share this post


Link to post
Share on other sites

I have also noticed if you come from a neutral port and then go into a port that should have the Admiralty button, it is disabled.

Has happened in Mortimer Town twice, once from Baracoa and once from Samana, the hotkey doesn't work either so it isn't that the button is just hidden

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Haggard Blanc said:

I have also noticed if you come from a neutral port and then go into a port that should have the Admiralty button, it is disabled.

Has happened in Mortimer Town twice, once from Baracoa and once from Samana, the hotkey doesn't work either so it isn't that the button is just hidden

I didn't understand what was the reason but I can confirm that in my playing today I didn't had admiralty enabled , and i also come from a neutral port.

  • Like 1

Share this post


Link to post
Share on other sites

I want to add in the economy tab  i would prefer to collect the resources without the need to teleport to the ports where the building are. It seems a waste of time, special if you have many buildings in different ports,  to teleport just to collect the resources to stay in the warehouse.

  • Like 2

Share this post


Link to post
Share on other sites
Quote

C7F970E2A9FC259BFE192167F0EC1A574F5B00F3

I have no guns on my ship in Equipment tab, but my Aga in the docks has cannons on lower deck? No guns present at bow and stern. That's the only Agamemnon I have.

Also Frigate in my docks with all guns equiped has no guns present in docks:

Quote

864FF741AA8308829FE4B2054F2EF558A166EB83

Imagine me leaving docks after seeing cannons on my ship in the docks, but not actually having them equiped OMEGALUL

  • Like 1

Share this post


Link to post
Share on other sites

svDyqIN.png

 

So ran into an issue last night @admin. I asked around to see if others have had the same issue and all seem to have come up with similar issues caused by various things. From what I can tell I have all the material and have enough labor hours, yet am unable to produce anything. 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Davos Seaworth said:

svDyqIN.png

 

So ran into an issue last night @admin. I asked around to see if others have had the same issue and all seem to have come up with similar issues caused by various things. From what I can tell I have all the material and have enough labor hours, yet am unable to produce anything. 

Labor Hours: Required/Available ? Try using LH contracts

Share this post


Link to post
Share on other sites
Just now, Beeekonda said:

Labor Hours: Required/Available ? Try using LH contracts

That is a possibility but that would make no sense since would that mean every item would be the same required/available?

Share this post


Link to post
Share on other sites

Edit: Actually everything is right:

Available/Required

 

temp3.png

Edited by Beeekonda

Share this post


Link to post
Share on other sites

  When moving stuff from ship hold to warehouse and vice versa would be better if you could drag goods to the warehouse/hold icon and drop to put in/transfer.

 Would save having to open both to transfer,  which after 100 times could become kinda tiresome :) .

  Also when dropping stuff in WH/hold make it default to place new item at bottom and able to just drop on stuff and stacks with stuff in hold/WH already of same type,  scrolling down every time kinda drives me nuts also :D .

 

 

Edited by Dibbler

Share this post


Link to post
Share on other sites
24 minutes ago, Davos Seaworth said:

svDyqIN.png

 

So ran into an issue last night @admin. I asked around to see if others have had the same issue and all seem to have come up with similar issues caused by various things. From what I can tell I have all the material and have enough labor hours, yet am unable to produce anything. 

I just bugged my crafting, will post in a second

And I think you bugged it  the same way

PS: Re-opening Ship crafting solves issue for me, could you try it out?

Edited by Beeekonda

Share this post


Link to post
Share on other sites

@admin

Crafting ship using woods I don't have:

Teak/White Oak

Quote

0C194660AE9E03CAC49A0D7AAD5E12C03BEADF34

E910C8CB06B590FD64822C12604367E092C85BE3

 

Gives Error:

Quote

311A03822B160688260E33BE82096E77978BA109

Does says Not enough Teak Log, but does not says Not enough White Oak Log.

After that this instance of crafting Traders Lynx locks up, and even if I change woods to Fir/Crew Space its still locked up:

Quote

E58DD6EE6201AFC252FD702DF860DA37A0EFD3B7

Re-opening via double tap on Traders Lynx solved issue. Closing bugged window and re-opening also solved issue

Opening another blueprint while having bugged one open still works fine.

PS: I also made my docks full, that still allows you to hit Craft button but then says "Not enough space in docks"

Edited by Beeekonda

Share this post


Link to post
Share on other sites
13 minutes ago, Beeekonda said:

I just bugged my crafting, will post in a second

And I think you bugged it  the same way

PS: Re-opening Ship crafting solves issue for me, could you try it out?

I was running a char up and it got buggy.  So I closed all windows and reopen them and it worked for me.

Share this post


Link to post
Share on other sites

Why do provisions weigh 302.46?!?!  I can't transport them to my shipyard.  😕  And it takes 135 salt to make one which is hours of salt collecting.

Share this post


Link to post
Share on other sites

Thank you for the "active ship at the end of the pier" when in port.

Outposts button in the fast travel mode is very welcome.

the Tow to Port tied to a complete lock in shallows. I've never been stuck and used that tool as a way to avoid danger. 

I expect the Journal to be available in the fast travel mode very soon.

The review of the mass of resources, if are being brought to realistic weight values, are a step forward. Was strange to be able to transport several vessels, in materials, inside one transport vessel. But this is not about UI, sorry.

Keep up the good work. This update is a breeze of fresh air to us players that wish for a long term age of sail game - I know i will never get everything in a few months, so I plan to play for years - and well tied to historical authenticity as possible.

 

Edited by Cdr. Joseph Barss

Share this post


Link to post
Share on other sites
17 minutes ago, Cdr. Joseph Barss said:

The map travel mode. When not in battle.

Whay you need "Outposts button" in the open sea?

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Capn Rocko said:

Same issue here. I entered battle outside ocean bight and appeared at little inagua afterwards

Not complaining about it.  Its a good way to avoid the vultures who wait outside your battle to re-tag you.  Don't fix this @admin

Share this post


Link to post
Share on other sites
8 minutes ago, SnovaZdorowa said:

Whay you need "Outposts button" in the open sea?

Imagine sitting in the captain's cabin, while travelling, and consulting the log books and other documentation about the outposts.

Can consult what ships are at what outpost, what buildings, and any other information we can see as useful. Of course not information in real time, this is age of sail. 

Edited by Cdr. Joseph Barss
  • Like 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...