Jump to content
Game-Labs Forum
darthclide

infamous "nvidia display driver stopped responding and has recovered."

Recommended Posts

Tried compatability with W7 - wouldn't open the game when I changed it. Still getting crashes every 15min or so.

Did you try to delete GPU drivers and install the latest ones? Also, reinstalling the game?

Share this post


Link to post
Share on other sites

Got the same issue running on a watercooled GTX Titan.

 

My workaround is limiting the framerate to 30 fps, even though I could run it at 60 fps on high setting. This is sort of frustrating, but it's the only viable option that I have found.

 

According to this forum, the issue is around for more than a year now. Maybe devs should take a look into this.

Share this post


Link to post
Share on other sites

Got the same issue running on a watercooled GTX Titan.

 

My workaround is limiting the framerate to 30 fps, even though I could run it at 60 fps on high setting. This is sort of frustrating, but it's the only viable option that I have found.

 

According to this forum, the issue is around for more than a year now. Maybe devs should take a look into this.

Captain, did you also try to clocking gpu down a bit and check it with 60 fps?

Share this post


Link to post
Share on other sites

Captain, did you also try to clocking gpu down a bit and check it with 60 fps?

No, it is running at base clock in this game. What I will experiment with is target framerat in Nvidia driver. Maybe I can lock to 50 fps, because 30 fps shows a lot of stuttering on other ships.

Share this post


Link to post
Share on other sites

I had same problem few months ago it started when i updated nvidia drivers to the latest. i deleted drivers (theres some software for this i dnt remember name @google) then istalled older one it helped for some time. After ca month my Graphic Card burned out and i needed to buy new one but maybe its just coincidense.

 

you should also check cables connection.

Edited by pr0zac

Share this post


Link to post
Share on other sites

It has been mentioned by other players that they found the temporary workaround to fix perfomance issues by roll back to 15.02.2016 drivers version. Not sure if it will help in your case, but you could as well try it

Share this post


Link to post
Share on other sites

So many people must got this error while using the computer. It due to the TDR (Timeout detection and Recovery) when it find GPU has not responded within the allotted period of time then it restart the display drivers to help the user instead to restart the entirely computer. When i browsed to get the solution then https://appuals.com/fix-display-driver-stopped-responding-and-has-recovered help me to get the complete solution after following the guideline.

Share this post


Link to post
Share on other sites

i've had this problem for a long time also with other games

it usually occurs on win 7 x64 and it's an aero problem  if you disable aero everything is fine 

the solution to this (atleast for me) was a critical windows update / hotfix that was provided with my gigabyte motherboard CD

even if your motherboard is not Gigabyte you can download drivers from their page .. just select any socket 1151 motherboard and go to support-drivers select win 7 x64 and you should see it in there

Edited by John Sheppard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×