Jump to content
Game-Labs Forum
darthclide

infamous "nvidia display driver stopped responding and has recovered."

Recommended Posts

I'm not saying that this will help, but ... it's easy&safe to try out:

 

For high-end CPU's like yours I7, some people reported stability issues while playing Unity based games, when they had Hyper-Threading enabled.

You can try to disable HT in BIOS.

Share this post


Link to post
Share on other sites
Guest raat

I'm not saying that this will help, but ... it's easy&safe to try out:

 

For high-end CPU's like yours I7, some people reported stability issues while playing Unity based games, when they had Hyper-Threading enabled.

You can try to disable HT in BIOS.

 

hmm, interesting.  don't know I want to disable HT just for NA though.  Thanks for the tip.

 

Moreover though, games shouldn't really require disabling HT in this day and age to be stable.  If that is the issue, hopefully GL can work on that. :D

Share this post


Link to post
Share on other sites

I have the same problems...

I ve reinstalled windows , reinstalled the game tried older gpu drivers and newer ones , clocked my cpu down , i got myself a new storage and ram but the driver is still crashing.

My system: i7 4770k

Gigabyte sniper g1 z 97 mobo

Nvidia gtx 680 with 4gb

500w psu - but i ve tested my sytem and it took only 300w

I get this only when playing naval action and it makes this game unenjoyable.

So it would be nice if the devs would work on this proble since it seems like multiple users do have this issue.

Share this post


Link to post
Share on other sites
go into device manager  and DISABLE (not uninstall) all the Nvidia HD audio driver's.

 

 

This suggestion appears fairly often as a solution to this problem. 

  • Like 1

Share this post


Link to post
Share on other sites

There was only one nvidia audio driver, and it was called a virtual audio one... I disabled it, here is to hoping that when I stream it doesn't crash like this. You see, I would be perfectly fine with a "game stopped working" kind of crash because then it is simply a matter of restarting the game. However, due to me streaming, this crash is really really bad as it will stop the stream....

Share this post


Link to post
Share on other sites
Guest raat

I've had it happen less often when I lower my settings to "High" instead of "Ultra", darthclide.  Still happens, but far less often.

 

Sad really, because my computer is more than capable of "Ultra" with 60fps, but unfortunately, I can't enjoy that setting because of this issue...

Share this post


Link to post
Share on other sites

Yes, I randomly decided to try lowering the settings even though I can handle 60+ most of the time. I didn't crash for the rest of the stream but meh... this definitely needs attention.

Share this post


Link to post
Share on other sites

Yes it worked ... since yesterday now it s the same as before it happens multiple times a game .

I triede to re- and then deactivate the HD audio driver again which hadn t any effect .

I ll try to disable hyperthreading....tomorrow.

Share this post


Link to post
Share on other sites

I am not sure if my issue is the same or not.

I can be in a game and it drops me back to the desktop, and I can see in the taskbar I have Unity still visible.

I can hear all the sounds going on, but I am unable to "open" back up the game.

It doesn't show as unresponsive in Task Manager, and I can click the Unity icon on the task bar. It takes away the mouse cursor, but doesn't actually open up the game again.

Only option I have is to close the program and launch it again.

 

i7 4790k, GTX970, 16GB ram. All with the latest drivers and updates.

 

Getting to be really frustrating, especially since I had first round of 3 vs 3 in PVE Lights, and I got dropped out the moment I started actually moving. I had also played a game prior to that one, no problems.

Share this post


Link to post
Share on other sites

I am not sure if my issue is the same or not.

I can be in a game and it drops me back to the desktop, and I can see in the taskbar I have Unity still visible.

I can hear all the sounds going on, but I am unable to "open" back up the game.

It doesn't show as unresponsive in Task Manager, and I can click the Unity icon on the task bar. It takes away the mouse cursor, but doesn't actually open up the game again.

Only option I have is to close the program and launch it again.

 

i7 4790k, GTX970, 16GB ram. All with the latest drivers and updates.

 

Getting to be really frustrating, especially since I had first round of 3 vs 3 in PVE Lights, and I got dropped out the moment I started actually moving. I had also played a game prior to that one, no problems.

Yes thats the same i get.

Share this post


Link to post
Share on other sites

It could be your GTX card just can't take the load over a longer period of time.

 

I have had this problem with a few games that I play, most notorious are WarThunder and WoT (yeah, I know). No other games have this problem and I have had it happen to me once in Naval Action. If you have msi Afterburner running in the background the crashes usually happen if the game utilizing near or at 100% of the GPU capacity. I can probably play two or three games with the graphic set to whatever makes the maximum level, and then the graphic driver shuts down and crashes the game.

My solution has been to lower the settings one step down. from Maximum to High in WarThunder and from Ultra to High in Naval Action. No more crashes since the change - and the difference is not that noticeable.

I have a GTX 660 card and the PC specs are more than sufficient to be able to run these games on full, graphic wise. You don't really notice that the card has problems in the game as the graphic flows at more than enough fps... it just suddenly crashes. 

 

Try lowering the settings a tad and see if that helps. Going from Ultra to High in Naval Action isn't that much of a difference anyway. 

Share this post


Link to post
Share on other sites

It could be your GTX card just can't take the load over a longer period of time.

 

I have had this problem with a few games that I play, most notorious are WarThunder and WoT (yeah, I know). No other games have this problem and I have had it happen to me once in Naval Action. If you have msi Afterburner running in the background the crashes usually happen if the game utilizing near or at 100% of the GPU capacity. I can probably play two or three games with the graphic set to whatever makes the maximum level, and then the graphic driver shuts down and crashes the game.

My solution has been to lower the settings one step down. from Maximum to High in WarThunder and from Ultra to High in Naval Action. No more crashes since the change - and the difference is not that noticeable.

I have a GTX 660 card and the PC specs are more than sufficient to be able to run these games on full, graphic wise. You don't really notice that the card has problems in the game as the graphic flows at more than enough fps... it just suddenly crashes. 

 

Try lowering the settings a tad and see if that helps. Going from Ultra to High in Naval Action isn't that much of a difference anyway. 

I highly doubt that my GTX970 is unable to handle this game...

As mentioned in other previous posts, HT on or off doesn't make a difference, HD Audio enabled or disabled doesn't make a difference, and changing down from ULTRA settings also doesn't make a difference.

 

Going to try the window mode, but considering I'm only running 1920 x 1080, it isn't exactly stressing out the system.

Hell, the fan on my GTX970 barely even has to power on!

 

And I also play WoT, at maximum setting for everything, running a steady 80 - 110 fps. Since you play WoT also, you know what sort of power this rig has to be able to do that.

 

Now don't get me wrong, it may be that nVidia cards are the common factor, but it certainly isn't due to lack of power, it is some other issue, that in this case may well be either a programming issue, or a Unity issue.

Share this post


Link to post
Share on other sites

I highly doubt that my GTX970 is unable to handle this game...

As mentioned in other previous posts, HT on or off doesn't make a difference, HD Audio enabled or disabled doesn't make a difference, and changing down from ULTRA settings also doesn't make a difference.

 

Going to try the window mode, but considering I'm only running 1920 x 1080, it isn't exactly stressing out the system.

Hell, the fan on my GTX970 barely even has to power on!

 

And I also play WoT, at maximum setting for everything, running a steady 80 - 110 fps. Since you play WoT also, you know what sort of power this rig has to be able to do that.

 

Now don't get me wrong, it may be that nVidia cards are the common factor, but it certainly isn't due to lack of power, it is some other issue, that in this case may well be either a programming issue, or a Unity issue.

I hear ya...

 

Both fan and temperature is way under critical levels (on full graphic settings - everything turned on and on max) but the games crash if the GPU utilization goes above 60-70% (with small peaks reaching 90-100%).

Having the games on the predefined High settings makes them perfectly stable (making a custom setup of the High settings also causes crashes).

 

And as it is the graphic driver that crashes when it crashes, makes it suspiciously a driver issue or some form of unhandled exception in the driver code. Which is kinda no-no in the coding business.

Share this post


Link to post
Share on other sites
Guest raat

I hear ya...

 

Both fan and temperature is way under critical levels (on full graphic settings - everything turned on and on max) but the games crash if the GPU utilization goes above 60-70% (with small peaks reaching 90-100%).

Having the games on the predefined High settings makes them perfectly stable (making a custom setup of the High settings also causes crashes).

 

And as it is the graphic driver that crashes when it crashes, makes it suspiciously a driver issue or some form of unhandled exception in the driver code. Which is kinda no-no in the coding business.

 

Yeah, it's not that it isn't the GPU.  It clearly is related to the GPU and Windows Timeout Detection "bs"...however, the problem still lies with the game or engine because no other games have this issue (at least for me).  And having a very nice GPU, but being unable to use it to its full potential is extremely frustrating especially when you know there's no reason it couldn't run "Ultra" settings simply because of some buggy issue with the game...

 

Since lowering my graphics setting, I've had way less crashes, yes, but that isn't a solution in my eyes.  This is a problem that needs to be address.  I'm sure the developers would like me to be able to play the game as they intended it in all its beauty, and not instead be frustrated while playing thinking the whole time of how it could look...

 

Now, I'm sure the difference is slight between "High" and "Ultra", but I'm also sure that we gamers (and I know in my case) spend quite a bit of money on our computers just to be able to see that slight difference.

 

While it probably isn't the most pressing issue, I sincerely hope that GL takes time to identify and fix this issue at least before the game releases.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah, it's not that it isn't the GPU.  It clearly is related to the GPU and Windows Timeout Detection "bs"...however, the problem still lies with the game or engine because no other games have this issue (at least for me).  And having a very nice GPU, but being unable to use it to its full potential is extremely frustrating especially when you know there's no reason it couldn't run "Ultra" settings simply because of some buggy issue with the game...

 

Since lowering my graphics setting, I've had way less crashes, yes, but that isn't a solution in my eyes.  This is a problem that needs to be address.  I'm sure the developers would like me to be able to play the game as they intended it in all its beauty, and not instead be frustrated while playing thinking the whole time of how it could look...

 

Now, I'm sure the difference is slight between "High" and "Ultra", but I'm also sure that we gamers (and I know in my case) spend quite a bit of money on our computers just to be able to see that slight difference.

 

While it probably isn't the most pressing issue, I sincerely hope that GL takes time to identify and fix this issue at least before the game releases.

 

Please bear in mind that this isn't an even remotely finished project.  Graphics optimizations are still yet to be performed, so I believe you can count on better performance, and better usage of resources in the various modes once the Devs circle back around to graphics/graphics optimizations.  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×