Jump to content
Game-Labs Forum
Sign in to follow this  
Alex B.

Technical problems. Reporting guide. Known issues and their solutions.

Recommended Posts

Automatic error reporting system sends information about all arising errors during game. This system works automatically so no any manual actions are needed.

 

Automatic crash reporting system sends stored information about client crashes. This is done just after user is logged in to the game. System also works automatically so no any manual actions are needed.

 

Manual bug reporting can be done by pressing F11 hotkey or corresponding UI button at any time. Please use it to report any gameplay, visual, audio or others bugs. Report number automatically is copied to clipboard after report is successfully sent. You can insert it when posting problem on game forum. 

 

Manual crash reporting system can be started by user via Steam launch option "Report crash". Please use this system in order to report problems if other bug reporting systems do not work, or game cannot be launched by some reason. You can also leave your email in "description" field in order for us to contact you to investigate problem. Report number automatically copied to buffer after successfully sending report. You can insert it when post problem on game forum. 

 

Connection Test system can be started by user via Steam launch option "Report connection Test". This system automatically checks network connection with game servers. Please use this system in order to report connection issues if you have problems with connection to our servers (lags, login errors, disconnects etc). Report number is automatically copied to clipboard after report is successfully sent. You can insert it when posting problem on game forum. In case, when report can't be sent you will see error message, please press "Open file location" button and attach file to forum post manually.

 

! Manual logs upload In case when all reporting systems do not work you can do manual compressing of game logs (..\Steam\steamapps\common\Naval Action\logs and crash logs - folders with date name) and attach logs archive to forum post with problem description.

Share this post


Link to post
Share on other sites

List of network ports needed for correct work game client.

If you have some problems  with connection to server (data is not loaded in Port, exit to Open World is not working, empty chat or entering battles is not working) check that 7770, 8089, 5672, 5222, 8080, 21020-21036, 7401-7600 ports are available in your network and PC.

 

Checking network connection to game servers (using tracert)

Connection issues (login errors, random disconnects etc.) can be caused by problems with intermediate network providers between client machine and game servers. Connection can be tested using Windows tracert utility by the following steps:

  • Open Windows Command Prompt (press Windows + R and type cmd, press enter afterwards)
  • Type: tracert <server_address> and press enter (example: tracert 89.163.234.93)
  • Wait until command fully finishes. Presence of "*" as well as high values (300ms and more) in output result could be caused by problems with intermediate server. Note name of the server for corresponding line
  • You can copy results to clipboard by right-clicking on console -> Select All and pressing enter afterwards
  • Also could be useful to do regular ping to server, for this open Command Prompt and type: ping <server_address> -n 25 (example: ping 89.163.234.93 -n 25)

Share this post


Link to post
Share on other sites
Here described main types of technical problems that could be faced in game and how to fix these.
1. Login message: Error: wrong protocol version.

This message can be displayed after server update. Please check new game client version in Steam app. Sometimes Steam don't show update immediately, in this case please restart Steam app.  

 
2. Login message: Error: wrong client version. Actual: ***; Required ***

This message can be displayed after server update. Please check new game client version in Steam app. Sometimes Steam don't show update immediately, in this case please restart Steam app.   

 
3. Login message: Client data corrupted. Please verify integrity of game files.

Please use "Verify integrity of game cache..." in Steam app. If message repeats please delete manually all files in folder ..\Steam\steamapps\common\Naval Action and verify game cache again

 
4. Login message: Server is under maintenance.

This message can be displayed when servers are updating or servers are currently under daily maintenance. You can check servers status on game forum, topic Open world server status   

 

5. Login message: Server is off.

This message can be displayed when server is down due to technical problem or we did manual shut down, in this case will be posted corresponding message in game forum topic Open world server status   

 
6. Login message: Game requires shader model 5 Your shader model is ***.

It means that our game is not supported your graphic video card.

 
7. Login message: Required libraries could not be loaded. Please verify game cache integrity and make sure you installed Microsoft Visual C++ Redistributable 2013 (x86/x64).

This message is displayed when required libraries could not be loaded. Please install  Microsoft Visual C++ Redistributable 2013 x86 for x86 systems and x86/x64 for x64 systems, DirectX Jun2010 or newer. You can download these Microsoft Visual C++ Redistributable 2013, DirectX  on official Microsoft server

 
8. Login message: Authentication error: UserId received from Steam is empty.

This message can be displayed when Steam server don't work or work incorrect. Please try restart Steam app. 

 

9. Login message: Connection error: Please try relogin.

This message can be displayed when player account is connected to game server. When you close game client your player account still connected on server from 15 to 30 sec, that's why you can't reconnect to server more often than ~30 sec. Sometimes, game client can still running as Windows processes after closing game window, in this case try kill process in windows task manager and restart game app. 

Share this post


Link to post
Share on other sites

I want my money back.

It is not because You do not remember the promises you do make i do not remember them!

And the fact that you make people participate in the testing of your product how imperfect it is so you do not pay them to test this game but let them pay you?!

So I am asking my money back for having lost my time in waiting for a product you shall never providing in commercial terms this is stealing!

I f during production of a product and this is a commercial product that producer changes the characteristic of this product the customer may change is mind and is down payment shall be refunded. This a common commercial law. But maybe not in the Ukraine democratic republic?!

Share this post


Link to post
Share on other sites

 

List of network ports needed for correct work game client.

If you have some problems  with connection to server (data is not loaded in Port, exit to Open World is not working, empty chat or entering battles is not working) check that 7770, 8089, 5672, 5222, 3270, 21020-21036, 7401-7600 ports are available in your network and PC.

 

Checking network connection to game servers (using tracert)

Connection issues (login errors, random disconnects etc.) can be caused by problems with intermediate network providers between client machine and game servers. Connection can be tested using Windows tracert utility by the following steps:

  • Open Windows Command Prompt (press Windows + R and type cmd, press enter afterwards)
  • Type: tracert <server_address> and press enter (example: tracert 89.163.234.93)
  • Wait until command fully finishes. Presence of "*" as well as high values (300ms and more) in output result could be caused by problems with intermediate server. Note name of the server for corresponding line
  • You can copy results to clipboard by right-clicking on console -> Select All and pressing enter afterwards
  • Also could be useful to do regular ping to server, for this open Command Prompt and type: ping <server_address> -n 25 (example: ping 89.163.234.93 -n 25)

 

Is there any solution to this?

Everything was working fine for me, and then all of a sudden after a server restart I started getting this problem.

I will run the tracert tonight and see what happens.

How do I check if the ports are available?

Share this post


Link to post
Share on other sites

There's no real "solution" per se - the game needs those ports in order to communicate correctly with the server.  The solution is to configure your network/firewall to allow the game the access that it needs.  The game can't work otherwise.

 

Regarding getting the problems only after a server restart, that is more of concern to me.  Please use Google for your particular brand of anti-virus/firewall to figure out how to tell if particular traffic is getting blocked.  If you suspect it's your network, try using someone else's network (someone with a different service provider, not someone in the same building/dorm/etc if applicable) to see if it works there.  If it still doesn't work there, it's more possible that the problem is in your local computer's setup.

Share this post


Link to post
Share on other sites

got any idea as why i keep getting Error: Login queue request failed and Login credentials request failed ?

same here. game starts up and that's what happens. network is good.

 
Pinging 89.163.234.93 with 32 bytes of data:
Reply from 89.163.234.93: bytes=32 time=111ms TTL=112
Reply from 89.163.234.93: bytes=32 time=108ms TTL=112
Reply from 89.163.234.93: bytes=32 time=109ms TTL=112
Reply from 89.163.234.93: bytes=32 time=111ms TTL=112
Reply from 89.163.234.93: bytes=32 time=107ms TTL=112
 
 
restarted steam. same prob.
 
EDIT: got it to work by signing in on x86 variant. Running win 8.1.
Edited by skypickle

Share this post


Link to post
Share on other sites

Please check that router/software is not blocking ports 7770, 8089, 5672, 5222, 8080, 21020-21036, 7401-7600 for the game, also turn off all programs which use internet heavily (like torrent programs, netflix clients, K9 kind of software etc.), disable antivirus, firewall any other protection/filtering software, also, you can try to put your router into DMZ mode.

 

If this won't help please send report through Steam Launch option "Report Connection Test" and post report name here (it will look like NAS-XXXX)

Share this post


Link to post
Share on other sites

Please check that router/software is not blocking ports 7770, 8089, 5672, 5222, 8080, 21020-21036, 7401-7600 for the game, also turn off all programs which use internet heavily (like torrent programs, netflix clients, K9 kind of software etc.), disable antivirus, firewall any other protection/filtering software, also, you can try to put your router into DMZ mode.

 

If this won't help please send report through Steam Launch option "Report Connection Test" and post report name here (it will look like NAS-XXXX)

Thank you it works fine now  :D

Share this post


Link to post
Share on other sites

Ahoy, everyone.  I have been having issues with spawning.  I start the game, go into a server and play but after I leave a battle it spawns me without a ship and half in the water without any camera movement available.  "Home" key not working.  only option is to quit the game Via "Esc"
I try to rejoin same server and it loads me straight back into where I was. No ship and half in water.
I exit game once again and delete profile and make another.  Go into server. Great works.  Again after leaving a battle, I`m half in water and no ship.  What on earth is goin on?

 

Share this post


Link to post
Share on other sites

Ahoy, everyone.  I have been having issues with spawning.  I start the game, go into a server and play but after I leave a battle it spawns me without a ship and half in the water without any camera movement available.  "Home" key not working.  only option is to quit the game Via "Esc"

I try to rejoin same server and it loads me straight back into where I was. No ship and half in water.

I exit game once again and delete profile and make another.  Go into server. Great works.  Again after leaving a battle, I`m half in water and no ship.  What on earth is goin on?

Could you please send a bug report through F11 bug reporter right after it happened? Also run the connection test report (4-th option in the stem launcher), it might freeze a bit, don't worry, it is working, just wait till it send the report. 

 

Meanwhile, please check that router/software is not blocking ports 7770, 8089, 5672, 5222, 8080, 21020-21036, 7401-7600 for the game, also turn off all programs which use internet heavily (like torrent programs, netflix clients), disable antivirus, turn off k9 web protection filter or similar to that filters, also, you can try to put your router into DMZ mode

Share this post


Link to post
Share on other sites

 

List of network ports needed for correct work game client.

If you have some problems  with connection to server (data is not loaded in Port, exit to Open World is not working, empty chat or entering battles is not working) check that 7770, 8089, 5672, 5222, 8080, 21020-21036, 7401-7600 ports are available in your network and PC.

 

Checking network connection to game servers (using tracert)

Connection issues (login errors, random disconnects etc.) can be caused by problems with intermediate network providers between client machine and game servers. Connection can be tested using Windows tracert utility by the following steps:

  • Open Windows Command Prompt (press Windows + R and type cmd, press enter afterwards)
  • Type: tracert <server_address> and press enter (example: tracert 89.163.234.93)
  • Wait until command fully finishes. Presence of "*" as well as high values (300ms and more) in output result could be caused by problems with intermediate server. Note name of the server for corresponding line
  • You can copy results to clipboard by right-clicking on console -> Select All and pressing enter afterwards
  • Also could be useful to do regular ping to server, for this open Command Prompt and type: ping <server_address> -n 25 (example: ping 89.163.234.93 -n 25)

 

 

I checked the antivirus and firewall, and both have permission on Naval action and steam.

The ports seems all open, at least on the router, on the main modem is hardly to check, because the ISP program like a dog without paws, and that thing is harder to read, than an old egyptian comic.

 

I can play for 3 hours and don't have a problem, and then play for a single hour and get logged off to the logging menu 3 times. I simple click "log-in" and the game rejoin without problem(if there is no queue :P), like he lose connection for half a second, get into panic mode and then calm down.

 

Compiled a test report on PvP One EU, number of it is: NAS-118652

And IP check and Tracert:

Tracert 89.163.234.93 on 30 points.

  1     4 ms     3 ms     4 ms  Home network Router

  2     4 ms     4 ms     4 ms  Home network ISP MOdem

  3     7 ms     6 ms     8 ms  net-2-32-40-1.cust.vodafonedsl.it

  4     7 ms     7 ms     6 ms  83.224.40.121

  5     6 ms     7 ms     6 ms  83.224.40.122

  6    11 ms    11 ms    10 ms  85.205.14.101

  7    18 ms     7 ms    14 ms  atrato.mix-it.net [217.29.66.107]

  8    25 ms    25 ms    27 ms  ae02.edge01.zur01.ch.as5580.net [78.152.59.82]

  9     *        *        *     Request Dropped.

 10     *        *        *     Request Dropped..

 11    24 ms    25 ms    25 ms  ae01.edge01.dus01.de.as5580.net [80.94.64.133]

 12    24 ms    23 ms    23 ms  78.152.32.59

 13    35 ms    26 ms    23 ms  ve531.ae10.brip-a.dus1-de.myloc.de [62.141.47.18

5]

 14    20 ms    20 ms    20 ms  89.163.234.93

Tracks complete.

ping 89.163.234.93 -n 25

Execution of Ping 89.163.234.93 con 32 byte di dati:

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=22ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=21ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=19ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=21ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=22ms TTL=117

Answer from 89.163.234.93: byte=32 Duration=20ms TTL=117

Statics Ping for 89.163.234.93:

    Packets: Send = 25, Received = 25,

    Lost = 0 (0% lost),

Average Packets time in ms:

    Min = 19ms, Max =  22ms, Average =  20ms

 

Share this post


Link to post
Share on other sites

Is there a way to solve multiple gameplay crashes daily with my automated crash reports sent to the devs? Same ingame character name. I switched security suites. I've tried basically everything and have a higher end gaming rig with everything current hardware and os-wise. I'm getting booted from the game multiple times daily STILL. Like more than any other game I've ever played - and I need a workaround, because I love the game. Thanks! I've manually set everything in several different firewalls (win10, Norton, Avast). Help!

Share this post


Link to post
Share on other sites

Captain, please, provide more details - does the game crash to desktop or you are forced back to server list? Please provide more details about it, also PC specs, connection etc.

As the first step try to set Compatibility Mode with Windows 7 on the both client.exe and client_,exe files (here \SteamApps\common\Naval Action)

Share this post


Link to post
Share on other sites

 I am having the same problem as JPJohns in the last 24 hours , nothing has changed on my system for months except your so called up dates, I find your error reporting tool as useless as the current NA 

 how can I even attach the crash file, if your final program is like this it will be a total failure. if the game was working yesterday and crashes every ten min now what has changed 

finally you early maintenance today indicates to me it is you side.which is failing please sort this out. 

Edited by ianhclark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×