Jump to content
Game-Labs Forum
Sign in to follow this  
Anolytic

Alert to Teamspeak users

Recommended Posts

I think that this can be considered sort of a public service announcement:

If I'm not mistaken, a fair number of Naval Action players are having, or starting to have, trouble connecting to their favourite Teamspeaks right about now. I can assure you if you are experiencing this, you are not alone. 

In the last couple of days Teamspeak has updated their official client to version 3.2.0 and most recently, today, 3.2.1. And when you start your client you get a prompt suggesting that you download and install the new client version. 

This new client does not support connecting to Teamspeak servers that are older than 3.1.x. If you try to do so, you will get a message saying:

Quote

Disconnected from server (server version is too old for command)

There is simply no way around this.

A quick look around has revealed to me that many Teamspeak servers used by Naval Action groups, apart from those rented from professional hosts, appear not to have been updated to version 3.1.x or newer yet.

My own two servers (the Russian TS and the old Danish TS) are included in this tally. Having been away from Naval Action for about half a year (can't believe it's been this long!), I have not done maintenance on my servers in that period after 3.1.0 was released. Hence I will be updating my own servers to 3.3.0 tonight, as soon as I am able (if you're a user of these Teamspeaks, expect some downtime).

I advice all other players that host Teamspeaks for Naval Action to update their servers to the newest version asap. 

If you are a player that use a server which has not been updated past 3.1.0, contact your server's owner/host and ask them to update to the newest version asap.

To those who haven't yet done so on auto-pilot, it may be advisable to wait a few more days or weeks before following the prompt to update your Teamspeak client to 3.2.0 or 3.2.1.

/end of public service announcement

  • Like 7

Share this post


Link to post
Share on other sites

If you google on the interwebs, there is a way to downgrade your teamspeak version that can allow you to connect to these old servers again. So if your host is a stubborn old bat then you can still join their server. Another option for you 🤷‍♀️ For those that wonder where to get it from, I got my older version from here: http://ftp.4players.de/pub/hosted/ts3/releases/ 

Although you should obviously update eventually, but for short term

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×