Jump to content
Game-Labs Forum
Sign in to follow this  
Banished Privateer

Battle Swords

Recommended Posts

This bug was in the game for ages, sometimes it's gone for few weeks or months, but then it comes back. Today occurred twice, as I can't click the battle swords. It is really game breaking because I have to relog to fix it and it's often too late to join.

Share this post


Link to post
Share on other sites
3 minutes ago, Banished Privateer said:

This bug was in the game for ages, sometimes it's gone for few weeks or months, but then it comes back. Today occurred twice, as I can't click the battle swords. It is really game breaking because I have to relog to fix it and it's often too late to join.

CLICK f11 with mouse(do not press) and then you can click swords. works for me

Edited by HachiRoku
  • Like 3

Share this post


Link to post
Share on other sites

F11 works sometimes, but not always. I knew the workaround for many months.

The whole thing with battle swords, battles and player information is very glitchy and buggy. For example:

  1. if you spam join batton and battle closes at the same time, the "Battle Information" window will be stuck on your screen for a couple of minutes without the option to close it. 
  2. Very often clicking "join" button doesn't work, you have to click it 2-3 times usually in order to make it work.
  3. 0 BR ships in OW without the option to fix it (sometimes re-clicking works, but not always. there is no refresh button of any kind. This occurs even with perfect internet connection)
  4. If you leave the tagging circle before it goes to 0 seconds and get back to "invisible circle" after it went past 0 seconds, the battle will trigger anyway, all of sudden. 
  5. Ship positions in battle are often totally mismatched. I know that the position has about 1-second delay, but it doesn't change the fact that when I stay all the time behind my enemy and spawn in battle in front of him, it's hello kittyed up. 
Edited by Banished Privateer

Share this post


Link to post
Share on other sites
23 hours ago, Banished Privateer said:
  1. If you leave the tagging circle before it goes to 0 seconds and get back to "invisible circle" after it went past 0 seconds, the battle will trigger anyway, all of sudden.

what distance do you mean? Like 1 ship hull from the circle or like 10 ship hulls from the circle? If the distance is not too much the battle may trigger due to lag, ping and such, we have tested it on large distance and this is not reproducible, do you have a video perhaps?

Share this post


Link to post
Share on other sites
14 hours ago, Ink said:

what distance do you mean? Like 1 ship hull from the circle or like 10 ship hulls from the circle? If the distance is not too much the battle may trigger due to lag, ping and such, we have tested it on large distance and this is not reproducible, do you have a video perhaps?

Same thing happened to me few times, distance was aprox 5-6 ship hulls.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×