Jump to content
Game-Labs Forum
admin

Technical problems and bugs

Recommended Posts

Topics will be moderated heavily to stay on the subject. 

 

if you are reporting in game problems please use F11 report bug function

 

Format of the topic

 

In case of the problem

  • Problem
  • Why it is a problem
  • What should developers do to fix the problem

When discussing the problem please quote the problem you are referring to

Share this post


Link to post
Share on other sites

No problems yet (still installing) but as a side note.. Noticed the VC redistributable. I'm a 20 year veteran coder/project manager, Most projects these days are C#, however, cut my teeth on ANSI C and C++, including some work on DX8/9 based projects. If you ever need help with the debug of something..  I'm an very experienced spare set of eyes.

Share this post


Link to post
Share on other sites

  • PINK SKY & WATER (some battles only sky, some battles both sky and water)

Because I think sky & water must be blue  :lol:

Have some paintbrushers and make ART! :P

I have DX11. Nice rate of fraps.

DSC_0104.jpg

 

DSC_0105.jpg

 

 

21_11_2014_23_35_06.png

Edited by slik
moved the screenshots under the spoiler

Share this post


Link to post
Share on other sites

I was looking for some info:

 

http://answers.unity3d.com/questions/126487/custom-shader-turns-pink-when-built.html

 

http://answers.unity3d.com/questions/168624/everything-became-pink.html

 

 

 

I have read in one forum:

 

"[solution] Maybe a bit to old to reply to this post, but I had the same problem today, and fixed it by changing to another layout."

 

"Pink models means that the texture assigned to the model is missing. try to re-assign your texture to those model"

 

http://forum.unity3d.com/threads/unity3-problems-fresh-install.63284/

 

 

http://forum.unity3d.com/threads/sometimes-unity-displays-pink-colour-instead-some-things.93075/

Share this post


Link to post
Share on other sites

My logout of one of the matches:

 Initialize engine version: 4.5.1f3 (73cd57f80e3e)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 11.0 [level 10.1]
    Renderer: ATI Radeon HD 4300/4500 Series (ID=0x954f)
    Vendor:   ATI
    VRAM:     501 MB
Begin MonoManager ReloadAssembly
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\UnityEngine.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\I18N.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\I18N.West.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\I18N.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\I18N.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\I18N.West.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\I18N.West.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Ionic.Zip.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Ionic.Zip.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Newtonsoft.Json.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Newtonsoft.Json.dll into Unity Child Domain
- Completed reload, in  0.150 seconds
<RI> Initializing input.
 
<RI> Input initialized.
 
desktop: 1024x768 75Hz; virtual: 1024x768 at 0,0
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.dll (this message is harmless)
SteamAPI: Checking if need restart app...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
SteamAPI: Initializing...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
SteamAPI: Getting local Auth ticket...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
SteamAPI: Starting local Auth session...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
SteamAPI: Checking license..
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
SteamAPI: License OK
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.Xml.Linq.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.Xml.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.Configuration.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.Runtime.Serialization.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\System.Data.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\SteamApps\common\Naval Action\NavalActionCrashSender_Data\Managed\Mono.Security.dll (this message is harmless)

Edited by slik
moved the log under the spoiler

Share this post


Link to post
Share on other sites

1. Joysticks and other game controllers affect rudder control by applying constant input. Or, to put it simply, my rudder was hard to port until I disconnected my joystick and other flight controllers.

 

2. Affects rudder. Solved when the controllers are unplugged, but this is a nuisance for gamers.

 

3. Allow removal of inputs, not just replacement.

Share this post


Link to post
Share on other sites

I have tryed to change my graphic hardware and its solved now. I passed from an ATI Radeon HD 4300 to an ATI Radeon HD 5350. Runs perfectly. Nice rate of frames. Nice sailing. Nice battles. It's all ABSOLUTELY FANTASTIC!

Share this post


Link to post
Share on other sites

ATI Radeon HD 4300 doesn't support DirectX 11.

 

From the specs:

DirectX Version Support: DirectX 10.1

 

My mistake, then. I don't know why DXDIAG told me that the version of DirectX is 11. Anyway, solved.

 

Thank you, Slik!

Share this post


Link to post
Share on other sites

My mistake, then. I don't know why DXDIAG told me that the version of DirectX is 11. Anyway, solved.

 

Thank you, Slik!

You may have installed DirectX 11 (software layer), but the videocard have to support it (on hardware layer).

Share this post


Link to post
Share on other sites

I don't know where else to post this so I will start here.

 

Problem: Certain players in pvp matches are sailing off over the horizon afk. It has been reported by others that some of these players will do this then shut the game down and relaunch another round in effect being in two instances at once. Those players that win the pvp match can not get credit because this griefer has sailed off and they have no clue where he is at or he is so far upwind that it takes the rest of the match time to beat upwind to sink them. I won a match in 30 minutes and spent another 30 minutes beating upwind after an afk player and only managed to sink him with three minutes left.

 

Solution:

AFK players don't effect the outcome. they are considered dead after a certain amount of time afk... say 5 minutes. or

start by making it impossible to be in two instances at once.

Share this post


Link to post
Share on other sites

To the developers well done with this game even in early access my first impressions are wow what a game with life like graphics although explosions from cannons maybe need work still 2D  and not enough carnage  the sea is beautiful the ships are epic well done however my issues are with the out of game interface very bland could use work such as artwork i think of those old Airfix models the paintings on the box front that inspired us to build models somthing like that on your main menu will help alot also when you scroll over an icon maybe a description pops up    I only had one huge issue after 6 battles of play on my 2nd battle once i exited and a few moments later i got a pop up giving me the previous battle details it was a lost on my third battle NO DETAILS after battle 4th battle was a victory but no details poped up for me and i didnt get the victory point  5th battle was a lost and i gotten the battle details the 6th battle was a victory and gotten the victory point and battle details so when i should have had 2 wons 4 losses i only got counted 1 won 3 losses  there is a bug in that i feel funny reporting a won not counting but its true and needs to be addressed for future players and the game  i hope it had been fixed already im sure it wont happen again or often but as you can see there will be alot of problems if not dealt with in future thank you 

Share this post


Link to post
Share on other sites

Also had tested an issue that need to accur when in pvp it appears sides dont get balanced at all at start of game its left upto players who can never be trusted   so with this in a small 4 v 4 match i tested another huge issue its possible for players to snipe matches with 3 seconds left on clock i sniped the match to prove this is an issue sorry to the players on that match but if this wasnt tested there will be issues with untrusted players sorry to those in the match but it was for greater good admins and develpors please fix these issues so matches dont get OPd

Share this post


Link to post
Share on other sites

Noticed a couple of things so far:

 

1:On the lynx there is a small glitch with the wood damage texture being projected on the barrels of the 6 pd guns. (havent spotted it on the cutter btw) at high graphics settings.

 

2: the HOME key camera doesnt work (or didn't work) after I lost a boarding action.  

Share this post


Link to post
Share on other sites

 

1:On the lynx there is a small glitch with the wood damage texture being projected on the barrels of the 6 pd guns. (havent spotted it on the cutter btw) at high graphics settings.

This is on every cannon in the game. Its a known bug wich has to be sorted out eventually.

Share this post


Link to post
Share on other sites

Cannot login. I get an error if I try to use my Steam account Steam: SteamAPI_Init()failed.I have also tried the default log in and cannot get in. If I try default I get bad user name or PW using my steam login id and PW or my naval action log in and pw

Share this post


Link to post
Share on other sites

Cannot login. I get an error if I try to use my Steam account Steam: SteamAPI_Init()failed.I have also tried the default log in and cannot get in. If I try default I get bad user name or PW using my steam login id and PW or my naval action log in and pw

Many have the same problem. Under steam login it says checking validation or something similar, under default if I enter my steam user name and password it says connecting, then goes no further. I have use steam for years and was early accessfrom day one on Ultimate General ( another game by the same developer) with zero problems. It's the same company... Go figure.

The last I heard was they were checking into it. I know there are quite a few in the same boat(pun) if that's amkes you feel better.

Share this post


Link to post
Share on other sites

At first I thought that trying to record footage of the game froze my game. But later on realized something weird.

 

I had my "start recording" button mapped to F8. But somehow (and don't ask me why because I don't know what F8 is supposed to do in game) freezes Naval action for me, completely. I swapped my record button to F9 and now I can happily record footage. F8 still freezes the game, though, and I need task manager to close it when that happens.

 

Obviously that's more a nuisance that a real problem, but I have another one...in full screen alt-tabbing also freezes the game. And that one is a bit more important ;). Running it windowed for the time being, but hopefully alt-tab will be less of a problem on later builds :).

Share this post


Link to post
Share on other sites

Had an issue where my PC restarted mid-match for no discernible reason during a PvE game.

 

I'm going through the event log and crash dump as we speak to see if the problem is Unity/NA-related or a hardware issue I'm having.  Will post results ASAP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×